DAB reception flakey

Faults and Technical chat for the Jaguar F-Pace.
Post Reply
bucklandswifty
Posts: 14
Joined: Sun Oct 28, 2018 8:13 am

DAB reception flakey

Post by bucklandswifty » Sun Aug 23, 2020 9:19 am

Hi all - since my last service in late July 2020 my DAB radio reception has been very hit and miss, this is in my local area which had no issues before the service. I am not aware that they did any software updates but something has changed. Has anyone else noticed DAB performance issues?

Deux Points
Posts: 28
Joined: Sat Feb 25, 2017 1:00 pm

Re: DAB reception flakey

Post by Deux Points » Sun Aug 23, 2020 12:38 pm

My car was delivered new in June 2017, a 2018 model 3.0 S S/C. For the first service in May 2018, some software updates were done to fix the erratic reversing camera (my car has the basic / small screen). After that update, I lost commercial radio DAB stations very easily - BBC national was OK most of the time. After two weeks in the garage (Inchcape Guildford), the service department got the fix from their Land Rover colleagues via the LR Technical department. It was the modern equivalent of fitting some form of electrical interference suppression. I don't have more details but LR knew exactly what the problem was. DAB radio has been fine ever since.

RDB1
Posts: 128
Joined: Mon Feb 27, 2017 12:58 pm

Re: DAB reception flakey

Post by RDB1 » Mon Aug 24, 2020 9:39 am

Since new, my DAB does suddenly drop out from time to time but not enough to do anything about it. I have also noticed that it does so is almost the exact same spots (currently end of the Southampton runway on the M27) so I put this down to possible interference from air traffic and it does come back but if there is a fix I'll mention it as its going in for a service soon.
F-Pace 3.0D S - 2018, Corris grey, Pano Roof (fixed), Cold Climate Pack, ICTP 380W, Privacy glass, Spare wheel, Service Pack etc

bucklandswifty
Posts: 14
Joined: Sun Oct 28, 2018 8:13 am

Re: DAB reception flakey

Post by bucklandswifty » Tue Sep 15, 2020 8:54 am

Thanks all for the information, I will speak to my JLR dealer and see if they know of the LR solution. If I do get it fixed I will update this thread.

Post Reply