Phone only connects as media device

Faults and Technical chat for the Jaguar F-Pace.
Post Reply
ipcress
Posts: 7
Joined: Mon Aug 27, 2018 11:29 am

Phone only connects as media device

Post by ipcress » Sat Dec 29, 2018 10:21 pm

So just picked up my new to me F-Pace today.

Made sure the dealer updated ICTP to latest version which I've check and it's S18D.

Issue I've got is the phone (Google Pixel 2 running Andoid 9) connection was setup via Bluetooth ok and shows up as a connected device. I can play music from my phone, change track etc, but there is no phone functionality at all, phone icon on top left of ICTP screen has a line through it.

Sales guy who did the handover seemed to know what he was doing, spent half an hour trying to get it to pair correctly also tried to connect his iphone and had the same issues? The tick boxes for media and phone were selected and my bluetooth settings for phone, media and contacts were also selected?

Any ideas, before I lose the car for a day for a software reload?

Car's booked in for 2nd Jan for the software reload .................Looks like my Jaguar owners experience is off to the expected start :lol: :roll:
MY18 3.0D S


Jim
Posts: 863
Joined: Wed Sep 21, 2016 6:17 pm
Location: Telford, Shropshire

Re: Phone only connects as media device

Post by Jim » Sun Dec 30, 2018 12:01 am

Have you tried other Android phones?
Ex 2016, MY17 - 2.0 D, Portfolio - Dec 2018 RR Velar D300 HSE R-Dynamic


nphe9974
Posts: 45
Joined: Wed Feb 21, 2018 8:43 pm

Re: Phone only connects as media device

Post by nphe9974 » Sun Dec 30, 2018 8:02 am

It’s a 5 minute job so If the sales guy took half an hour I’d say he was probably out of his depth especially as a Pixel isn’t a common phone.

Have you tried deleting the connected device and adding it again - as part of the process it should ask what you want to use the device connection for e.g. phone, media etc.

The on line user manuals are pretty good setting out the steps.
F-Pace 3.0 d S, Ammonite Grey, ICTP


ipcress
Posts: 7
Joined: Mon Aug 27, 2018 11:29 am

Re: Phone only connects as media device

Post by ipcress » Sun Dec 30, 2018 5:55 pm

Jim wrote:
Sun Dec 30, 2018 12:01 am
Have you tried other Android phones?
No but as I as said it didn't work with his iphone either
nphe9974 wrote:
Sun Dec 30, 2018 8:02 am
It’s a 5 minute job so If the sales guy took half an hour I’d say he was probably out of his depth especially as a Pixel isn’t a common phone.

Have you tried deleting the connected device and adding it again - as part of the process it should ask what you want to use the device connection for e.g. phone, media etc.

The on line user manuals are pretty good setting out the steps.
Yes it is a quick job and I've deleted and re-paired the device several times but it still only works for media.

As you can see in the picture below the device is connected and everything is selected correctly, but the top left of screen shows that phone is not available.

Image

From the home screen if I tap on conneted to phone, I just get the 4 coloured rectangles and connecting but nothing happens.

Hopefully it will just be an ICTP reloaded and not a hardware issue. Obviously it's covered by the warranrty but it'll just be a PITA.
MY18 3.0D S


Jim
Posts: 863
Joined: Wed Sep 21, 2016 6:17 pm
Location: Telford, Shropshire

Re: Phone only connects as media device

Post by Jim » Mon Dec 31, 2018 8:57 am

When you first paired the phone to the car did it ask you to agree all the permissions for it to interact with the car?

I assume you have gotten both the phone and car to forget each other and tried pairing them from new?

If you have done the above and given the dealer's iPhone had the same issue it is quite likely the car has a Bluetooth fault. I've not seen this mentioned on the forum before.
Ex 2016, MY17 - 2.0 D, Portfolio - Dec 2018 RR Velar D300 HSE R-Dynamic


ipcress
Posts: 7
Joined: Mon Aug 27, 2018 11:29 am

Re: Phone only connects as media device

Post by ipcress » Mon Dec 31, 2018 11:17 pm

@jim Yes deleted previous connections from vehicle and phone before reconnecting phone.

Weirdly today had incoming call whilst in car, phone rang, then rang through car for two rings then went back to phone....🤔

Car is booked in for 2nd Jan for diagnostics/software reload, but I think it's going to end up as a hardware issue☹️
MY18 3.0D S


ipcress
Posts: 7
Joined: Mon Aug 27, 2018 11:29 am

Re: Phone only connects as media device

Post by ipcress » Thu Jan 03, 2019 10:11 pm

Took the vehicle back in yesterday and they did a software reload, took them 2 1/2 hours.

Phone now functions as expected, so I'm a happy chap. 👍
MY18 3.0D S


Post Reply

Return to “Faults & Technical Discussions”