ICTP Patch 4.0

Faults and Technical chat for the Jaguar F-Pace.
User avatar
KeithL
Posts: 148
Joined: Sun Jul 22, 2018 7:18 am
Location: Worcestershire

Re: ICTP Patch 4.0

Post by KeithL » Mon Apr 15, 2019 5:08 pm

19A seems to be working fine for me and seems to have fixed most of the problems , although some were intermittent and so I can't be absolutely certain. The auto/light/dark thing is irritating but I tend to run with it set to 'light' anyway so not a big deal. The voice control works as well as it ever did.....

The only thing I have noticed, which I am now thinking may be linked to the 19A upgrade, relates to the seat belt warning indicators. I am sure that before, as soon as you sat in the seat the red seat belt indicator came on for that seat, only switching to green when you put your seat belt on. If you took it off it went back to red. Now, if you sit in the seat there is no red warning. It goes to green when you put your seat belt on, and goes to red if you take it off again. It now means you can drive away without your selt belts on without any warning at all. Has anyone else noticed this since going to 19A or is it a) unrelated to the upgrade or b) I just have a dreadful memory and it always worked like this?
2017 2.0 i4 Diesel (180PS) Auto AWD Portfolio in Indus Silver with ICTP


ptolemyiv
Posts: 41
Joined: Sun Sep 03, 2017 4:18 pm

Re: ICTP Patch 4.0

Post by ptolemyiv » Tue Apr 16, 2019 9:51 pm

corriescar66 wrote:
Mon Apr 15, 2019 10:23 am
Oh, and they still haven't fixed my USB media problem......
What was your USB media problem? I have a number and am awaiting the update from 18d to 19a in the hope they will fix them!
3L Petrol, Loire blue, Ultimate Black, Pano, AdaptLED, AadaptCC, BlindSpot, LaneKeep, Privacy, Parking, 18-way memory, ITCP, 825W, Cold Climate Pack


User avatar
Reggraham
Posts: 160
Joined: Wed Jun 27, 2018 7:49 am

Re: ICTP Patch 4.0

Post by Reggraham » Thu Apr 18, 2019 9:07 am

I had a look on Topix this week for something else and whilst I was there I looked at the F-Pace Software updates I found some interesting things there is an update to 19A, I still haven't got 19A yet, but 19A2 is available.
IMC (INFOTAINMENT MASTER CONTROLLER) - SOFTWARE VERSION: S19A_19.11.4-330884, ASSEMBLY PART NUMBER: LX73-19C204-BA (G2379676)
INCONTROL© TOUCH PRO 19A2
Release Date: 2019-03-26.
What is interesting was the note below on the release notes.
This release is only available when updating with Software Over The Air (SOTA)
F-Pace Portfolio MY19 25T Yulong While/Light Oyster 20" wheels, Park Pack, Drive Pack, Touch Pro nav pack
Range Rover Evoque Dynamic MY15 Firenze Red Black Pack, Park Pack


Smitten
Posts: 815
Joined: Mon Dec 11, 2017 9:53 am
Location: SW London

Re: ICTP Patch 4.0

Post by Smitten » Thu Apr 18, 2019 5:31 pm

I was told by my dealer today not to have the software update next week and to wait instead until phase 5 is available in a few weeks. He said book the car in during May for the phase 5 installation. Anyone else heard this?

Whatever version they have been uploading recently seems to have caused a few issues with total failure of the infotainment screen and satnav.

I think I will be waiting a few weeks for whatever joys phase 5/Patch 5.0 will bring :roll:
3.0d S, Santorini black, black pack, 22" black rims, LEDs, Priv, 350W, ICTP, Ebony interior, AdSR, space saver, config ambient, remote release, lumbar, winter pack, rear recline. Build date Friday 13/4/18 :D


June16
Posts: 1081
Joined: Wed Nov 16, 2016 10:45 pm

Re: ICTP Patch 4.0

Post by June16 » Thu Apr 18, 2019 6:10 pm

Yep been told to wait till May too .
MY18 Rsport 25t BRG , Ebony - Oyster, 18 way mem, Surround Cam, blis, ICTP, LED adaptive....etc


ptolemyiv
Posts: 41
Joined: Sun Sep 03, 2017 4:18 pm

Re: ICTP Patch 4.0

Post by ptolemyiv » Tue Apr 23, 2019 10:56 am

Did anyone get any more info on phase 5 or supposed issues it's fixing? Aside from my media woes, I also seem to be suffering from the car becoming super jumpy (again its driving my wife mad just going through the London streets).. Almost like a go cart rather than a big SUV! Is it really possible this could be a result of a bad software update and has anyone else noticed this? Currently on 18D I believe
3L Petrol, Loire blue, Ultimate Black, Pano, AdaptLED, AadaptCC, BlindSpot, LaneKeep, Privacy, Parking, 18-way memory, ITCP, 825W, Cold Climate Pack


User avatar
Reggraham
Posts: 160
Joined: Wed Jun 27, 2018 7:49 am

Re: ICTP Patch 4.0

Post by Reggraham » Tue Apr 23, 2019 2:52 pm

That would not be a media fault if the vehicle is jumpy I'd get it to a dealer to check that problem out. The infotainment software is effectively sandboxed from all the vehicle software so that it can't cause problems. It takes CAN bus feeds but all communications between media bits is over its own network.
All manufacturers do this as they realise the media system is more likely to crash than any other as it is one complete system, basically there is a small PC they call the infotainment master controller in the car. All other car electronics are semi-autonomous so that car functions can still operate even if one module goes faulty e.g Limp home mode.
F-Pace Portfolio MY19 25T Yulong While/Light Oyster 20" wheels, Park Pack, Drive Pack, Touch Pro nav pack
Range Rover Evoque Dynamic MY15 Firenze Red Black Pack, Park Pack


Smitten
Posts: 815
Joined: Mon Dec 11, 2017 9:53 am
Location: SW London

Re: ICTP Patch 4.0

Post by Smitten » Tue Apr 23, 2019 8:46 pm

ptolemyiv wrote:
Tue Apr 23, 2019 10:56 am
Did anyone get any more info on phase 5 or supposed issues it's fixing?
At the dealer today for first annual service. Reversing camera fault detected and asked to bring the car back in about 4 weeks to take care of it and phase 5 update at the same time. I have no further information on content of update.
3.0d S, Santorini black, black pack, 22" black rims, LEDs, Priv, 350W, ICTP, Ebony interior, AdSR, space saver, config ambient, remote release, lumbar, winter pack, rear recline. Build date Friday 13/4/18 :D


lozpace
Posts: 154
Joined: Sat Dec 02, 2017 2:29 pm

Re: ICTP Patch 4.0

Post by lozpace » Thu Apr 25, 2019 6:50 pm

KeithL wrote:
Mon Apr 15, 2019 5:08 pm
The only thing I have noticed, which I am now thinking may be linked to the 19A upgrade, relates to the seat belt warning indicators. I am sure that before, as soon as you sat in the seat the red seat belt indicator came on for that seat, only switching to green when you put your seat belt on. If you took it off it went back to red. Now, if you sit in the seat there is no red warning. It goes to green when you put your seat belt on, and goes to red if you take it off again. It now means you can drive away without your selt belts on without any warning at all. Has anyone else noticed this since going to 19A or is it a) unrelated to the upgrade or b) I just have a dreadful memory and it always worked like this?
Checked this on my car and it’s as you say no red icons anymore, I’m running 19A.
F Pace February 2018
2.0 litre 180ps AWD Automaic Portfolio, Santorini Black, 19” 5038 Wheels, Privacy Glass, ICTP 380watt, Heated Steering Wheel, Space Saver Spare, 4 way lumber, InControl Secure Tracker, Service Pack.


corriescar66
Posts: 1710
Joined: Tue Jun 28, 2016 12:22 pm

Re: ICTP Patch 4.0

Post by corriescar66 » Fri May 03, 2019 5:35 pm

ptolemyiv wrote:
Tue Apr 16, 2019 9:51 pm
corriescar66 wrote:
Mon Apr 15, 2019 10:23 am
Oh, and they still haven't fixed my USB media problem......
What was your USB media problem? I have a number and am awaiting the update from 18d to 19a in the hope they will fix them!
Same problem since v3.0......

It now does one of 3 things, though never the same more than twice in a row......

1) Can't find/recognise the USB stick at all (sometimes removing it & re-inserting it works)

2) Recognises the Stick without assistance, but starts from scratch from first track, listing only a few hundred tracks and will not allow ffwd or accept any commands until it's played that first track and the full 10k + songs are then listed/recognised

3) Works as designed, straight away - continuing where it was when you last switched the ignition off. Sometimes it remembers where it was days/ weeks later even if the car refuses to recognise it for all that time, then suddenly, unexpectedly, off it goes....

There is no improvement with 18C, 18D or 19A... And updating to these has mucked up other systems.... It goes in next week for the umpteenth time.... Yawn

Fortunately, the classic iPod, that originally didn't work, now blasts out the tunes as soon as the ignition button is pressed most of the time.... SO, if it worked properly, with voice control, artwork etc like my previous RRS did and ICT (not pro) loan cars did, then I wouldn't bother with the USB at all...


Post Reply

Return to “Faults & Technical Discussions”