Jaguar F-Pace Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter · #1 ·
After a week away where the F pace has not moved we returned to SD Card not detected.
The good wife said it had happened a couple of times but a retry normally sorts it.
I removed the SD card and cleaned it with no difference.
The SD card does work in the Laptop and the nav update mange reads it ok.
So hopefully its dirty contact on the reader in the car.
Has any cleaned these before? if so how?
I was thinking something like a lolly pop stick, clean one of course, soaked in IPA or similar.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #3 ·
I took mine apart last night - its easy enough to do, but was late and i didnt have a good iron so i plan on goign back to reflow the sd card reader to see if that helps. Also I found out there is a built in switch to detect the card and it is prone to wear so i will be having a look at that. I will post pics when i get around to it.
 

·
Registered
Joined
·
3 Posts
That would be appreciated, if you got it working, thank you. I imagine it's the same tech in the cars and I have no doubt it's an age thing, exacerbated by the heat. I have done nothing to cause it that I can imagine. Thanks
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #5 ·
From a disco sport forum where they use the exact same reader
"was getting the error, SD CARD NOT DETECTED etc.
Sat nav was very slow and getting the errors popping up more frequently as time passed so i tried a new sd card ScanDisk 64gb bit overkill but i got it cheap also it has a read speed of 170mb, probably a lot faster read speed than the original,
So formatted it to FAT32 and copied the contents over from original sd card, now after 2 weeks Works as it should, NO more errors popping up and its alot more responsive and starts up a lot faster just thought i would let you know may help some one having the same trouble, "

another said the dealer changed out the card and reader.
 

·
Registered
Joined
·
3 Posts
"was getting the error, SD CARD NOT DETECTED etc.
Sat nav was very slow and getting the errors popping up more frequently as time passed so i tried a new sd card ScanDisk 64gb bit overkill but i got it cheap also it has a read speed of 170mb, probably a lot faster read speed than the original,
So formatted it to FAT32 and copied the contents over from original sd card, now after 2 weeks Works as it should, NO more errors popping up and its alot more responsive and starts up a lot faster just thought i would let you know may help some one having the same trouble, "
Great, got to be worth a try before I give JLR £200+. It's more the inconvenience of getting the car there.. Thanks! Will give it a go.
I am only lacking voice dialling (I can still receive calls and make them from my phone) and maps. Neither is critical to me as I find Google maps much superior anyway, but if an easy fix like this works, that would be excellent.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #7 ·
yeah think i wil do this before major surgery on the reader as well
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #8 ·
I never got a new SD card but found an 8G integral in the back of a drawer late last night. All i did was copied the files over with no success.
I will try reformatting today and see before getting a high speed Scandisk.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #9 ·
A reformat did not cut it either - but i looked at the box and it has a whole upto 20M/s speed - wouldnt pull you out of bed these days. so i will get a faster one ordered up.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #10 ·
yeah new sandisk 32G formatted to FAT32 didn't cut it either.
Next step is to remove the reader and try a clean of the card contacts and reflow of the reader contacts to the PCB.
 
1 - 10 of 10 Posts
Top