Jaguar F-Pace Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Anyone else find getting in and turning on max demist makes screen really misted until engine heats up ?
 

·
Super Moderator
Joined
·
5,033 Posts
No, when i turn it on and the heated front screen it clears very quickly, one thing i do think that works well on the Fpace.
 

·
Registered
Joined
·
143 Posts
No misting on mine either.
A slightly different tack. I have noticed that sometimes the heated front and rear screens activate automatically on first start up. The amber lights aren't on but the screen clears leaving tell tale steamy bits on the edges.
Anyone else experiencing this??
 

·
Registered
Joined
·
577 Posts
Yes and the Frost light is lite to warn you of the cold temp. So below 4 C, I think you find the heated front and rear come on automatically on start up.
 

·
Registered
Joined
·
1,378 Posts
The misting up answer is this....spend a few minutes with kitchen roll and windowlene, buff it dry and it will take the film off the inside of the screen that you cannot see, and you will not suffer from misting again, repeat in a few months.

The only other issue maybe damp in the cabin, but that tends to affect older vehicles rather than new ones.
 

·
Registered
Joined
·
34 Posts
Hi
I have been experiencing misting up.
It happens randomly.

It usually happens on longer journeys when everything is very comfortable and then the whole vehicle , including the sun roof, mists up. Either opening the windows or putting the fan on full clears it after 3/4 minutes. But then it happens again after say 20/ 30 minutes.

I'm told it's a software problem, apparently some of the dampers in the a/c or vent system are not acting as they should.

I have thoroughly cleaned the glass internally with Autoglym Glass Polish but this hasn't stopped the misting up.

Has anyone else got this problem ?
 

·
Registered
Joined
·
4,228 Posts
Yes I've noticed on long journeys that all of a sudden the car goes very humid then a few minutes later the AC kicks back in and it goes really cold. Then 30 mins later it happens again. I've done 5 or 6 long journeys this week and noticed it on each.
 
1 - 9 of 9 Posts
Top