Jaguar F-Pace Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2018 F-Pace R-Sport with the technology package (connected navi Pro & Wi-Fi, 12.3" LCD...) I have seen that recently the InTouch SW loading hwne starting the car can take a very long time. I have a few recent cases it took over 10 minutes for the system to load. This means no navi, no media playing, control over seat heating, airflow... It seems to happen most frequently after a short stop when the car is turned off (i.e. filling up gas). But it has happened a few times when the car has been off for a while. I'm taking it in to the dealer tomorrow, but wanted to know if others had similar issues.
PS. I do the regular map updates the system brings up
 

·
Registered
Joined
·
554 Posts
It has good days and bad days, but never as long as 10 minutes. Sometimes it has sorted itself out before I get to drive away, other times it takes nearly a minute but yes, I have noticed it has been slower recently. Maybe it doesn't like the cold. Maybe the battery isn't fully charged so it waits until the alternator is up and running. Perhaps I'll put it on charge tomorrow and see if that makes a difference.
 

·
Registered
Joined
·
8 Posts
I had this problem too, took it to dealers, they did a "software upgrade" to clear it, never explained what it involved
Working fine but also seems a bit slower now than before
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I had this problem too, took it to dealers, they did a "software upgrade" to clear it, never explained what it involved
Working fine but also seems a bit slower now than before
I had this in the beginning too, and it imrpved a lot after a SW update during annual service. But it seems to nbegin again. It seems there is a SW buffer overload somewhere in the SW that after a while causes the issue. ;-)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
My F-Pace has been with the dealer for 4 weeks now trying to resolve this InTouch issue. Latest is that they - after a lot of convincing JLR in England - replaced system. But they are still having issues. I am not a happy camper right now. 🤬
 
1 - 5 of 5 Posts
Top