Jaguar F-Pace Forum banner

<t>Is you ICTP working 100% as it should be and are you happy with this product?</t>

  • <t>No</t>

    Votes: 20 50.0%
  • <t>Yes</t>

    Votes: 20 50.0%
1 - 17 of 17 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Ok folks - here the poll you asked for - are you ICTP owners happy?
 

·
Registered
Joined
·
612 Posts
FPTrevor said:
This will be interesting
Not really my point still stands from the previous thread. If 2000 people voted you could argue it a good sample size ... when 30 people vote the pool size can be too small and swing a poll dramatically in the wrong direction.

Most people here are enthusiasts or came here to post an issue, find a fix to an issue, or join in the reports of an issue - misery loves company.

So you have a small pool of people where only 1/4 didn't come here to complain ... and even that 1/4 may have problems.

The poll won't prove a thing I'm afraid... except that x number of people here are happy / unhappy
 

·
Registered
Joined
·
948 Posts
I ain't voting because it's too black and white in it's voting options, the vote should have said "ARE YOU HAPPY WITH YOUR ITCP"..... not working 100% whilst still being happy is very possible as is the case with me, mine has one issue but it's a minor one.

F#@k it I voted with what I feel is correct for me.
 

·
Registered
Joined
·
67 Posts
+1
Mine is not working 100% as it should, but i am very happy with it all the same.
Software updated booked for a fortnight and trust that it will rectify the niggles
 

·
Registered
Joined
·
4,228 Posts
^ yes you make a good point ... I don't expect 100% ... I would be happy with 95% .. currently I have:

Audio - 90% functionality - loses album art regularly - sometimes can't change track or album (screen registers press but nothing happens as per my recent video)

Cameras - 50% functionality - at the moment it's 50/50 whether you get a camera of not. If you don't then the only way to get it function again is turn the car off and wait for ICTP to power down completely.

Parking sensors - 80% functionality. About 1 in 5 times you won't get a parking sensor at all or you will get loud static instead. Again it requires a power down to reset.

Nav - 75% functionality - on an average journey I lose 3G connection for around 25% of the time which renders nav useless for me as I use it for traffic info.

Heating - 90% functionality - around 1 in 10 times I can't get the heated seats to respond.

General stability - 90% - around 1 in 10 starts take up to 30 seconds before I get anything on the screen. Weirdly this isn't from cold when it's almost instantaneous but when restarting after having stopped for petrol for example. Also it's very common after this for the screen to freeze and restart.

Warning to those who've not had it yet - mine is more unstable since the 2.5 update - so unless you need it I would avoid for now.
 

·
Registered
Joined
·
948 Posts
@JLRnumber5, your list of problems is considerable.... I must admit if I were in your shoes I too would be pissed.... the slow startup is something I suffered from in both RRSports with the old system along with the odd time of not recognising the phone. On that subject I need to add it to my list with ITCP as very occasionally the phone is slow to connect, sometimes up to 30 seconds from start up.
 

·
Registered
Joined
·
7 Posts
JLRnumber5 said:
^ yes you make a good point ... I don't expect 100% ... I would be happy with 95% .. currently I have:

Audio - 90% functionality - loses album art regularly - sometimes can't change track or album (screen registers press but nothing happens as per my recent video)

Cameras - 50% functionality - at the moment it's 50/50 whether you get a camera of not. If you don't then the only way to get it function again is turn the car off and wait for ICTP to power down completely.

Parking sensors - 80% functionality. About 1 in 5 times you won't get a parking sensor at all or you will get loud static instead. Again it requires a power down to reset.

Nav - 75% functionality - on an average journey I lose 3G connection for around 25% of the time which renders nav useless for me as I use it for traffic info.

Heating - 90% functionality - around 1 in 10 times I can't get the heated seats to respond.

General stability - 90% - around 1 in 10 starts take up to 30 seconds before I get anything on the screen. Weirdly this isn't from cold when it's almost instantaneous but when restarting after having stopped for petrol for example. Also it's very common after this for the screen to freeze and restart.

Warning to those who've not had it yet - mine is more unstable since the 2.5 update - so unless you need it I would avoid for now.
JLRnumber5 I just tried to reply to your PM but got an error message! If you PM me your email I will reply that way!
 

·
Registered
Joined
·
207 Posts
I think this poll needs to be split into 2 parts, as I don't think anyone has experienced a fully working ICTP to justify 'happy with it'.

For what it's worth I'm happy with mine, that's not to say it's problem free.
 

·
Registered
Joined
·
4,228 Posts
luminated said:
@JLRnumber5, your list of problems is considerable.... I must admit if I were in your shoes I too would be pissed.... the slow startup is something I suffered from in both RRSports with the old system along with the odd time of not recognising the phone. On that subject I need to add it to my list with ITCP as very occasionally the phone is slow to connect, sometimes up to 30 seconds from start up.
I'm not p1$$ed.

I just want a working system. This one isn't and they've had plenty of chances to get it right and now they have told me they've run out of ideas and I need to wait. So they can have this one back and send me a working one.

It's obvious from comments on here that Jaguar are perfectly capable of building a working one so fingers crossed.

I know I made a claim on an earlier post that if I went ahead and rejected I would not return to JLR but truth be told I love their cars. I simply can't bring myself to drive a Macan. The Cayenne is too old and too expensive. The new Q5 is so dull. The Q7 is too big. The GLC has a rubbish V6 diesel and gearbox or an insane petrol. I don't want another Evoque. The Disco Sport is mediocre.

The F Pace is the perfect car for me. When it works.
 

·
Registered
Joined
·
34 Posts
FP761 said:
I think this poll needs to be split into 2 parts, as I don't think anyone has experienced a fully working ICTP to justify 'happy with it'.

For what it's worth I'm happy with mine, that's not to say it's problem free.
As far as I can tell I have a fully working ICTP with no issues. I' very only had the car a couple of weeks but am yet to experience a single problem, let alone the multitude of issues that everyone one here seems to be struggling with.
 

·
Registered
Joined
·
90 Posts
Interestingly the ICTP software seems to be done at Jaguars Portland, Oregon location. (see link below from US Forum)

and the JLR guy that had a big part in the setup (head of future infotainment at JLR) has moved on..... cant blame him.

State of the art ethernet connections for the different Modules?

http://www.fpaceforum.com/forum/electronics/20986-ictp-tech-notes.html
 

·
Registered
Joined
·
90 Posts
just bumping this thread to show link to US Forum thread..... with links to iCTP development in Portland, Oregon.

makes sense to me if the issue is the (software) link between Modules of the ICTP Interface Master Controller.

In retrospect wouldn't it have been better to just go down the Apple Play or Android Drive route? even Porsche presently use that.
JLR must have seen the Audi virtual cockpit and thought.... I want some of that.
 
1 - 17 of 17 Posts
Top